[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - socket error # 0

socket error # 0

Help and advice on using Barca

Moderators: Eric, Tomas, robin

Results ...

Postby maxicomm » Thu Jul 24, 2008 12:48 am

Greetings,

OK ... built the PC and bunged Barca on and it installed OK and have been able to get it up and working by using the Restore function from the backup file on the other PC ... AND it works both in the send and receive mode on ALL accounts.

Now, here is the fun part ...

The installation which I've just done on the NEW pc has put BArca back to exactly how I remember setting it up ... including the default colour scheme etc

Now, having uninstalled Barca from the other PC where it is causing problems and then deleting the old files which were left behind, including doing a registry clean, when I reinstall and then restore from the SAME backup file that I used to restore the program on the new machine, BArca opens with a different colour scheme and the same old SMTP problem !!

So, the question then beggers the asking, where exactly is the new installation on the old machine getting the info from to default to the none standard colour scheme and to retain what ever error is causing the SMTP problem ?!?!?!!?

Anyone got any thoughts ????

Like I said already, after the uninstall, I cleaned the the registry with 'Registry Easy' ... which BTW is FAR superior to Regclean, and searched for any files which were associated with the Barca original install ... only left the download exe file (same file used to install on the new PC !) and as the new installation is trouble free, it can't be that then !!!

Somewhere on the OLD PC lurks a file which is affecting the restore or more likely the reinstallation from the exe file !!!

BIZARRE !!!!!!!!!!!!!!!!!!!!!!!!!!!
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Re: Results ...

Postby Eric » Thu Jul 24, 2008 6:00 am

maxicomm wrote:OK ... built the PC and bunged Barca on and it installed OK and have been able to get it up and working by using the Restore function from the backup file on the other PC ... AND it works both in the send and receive mode on ALL accounts.
Eureka, that's already good news that it's working. :)
Now, having uninstalled Barca from the other PC where it is causing problems and then deleting the old files which were left behind, including doing a registry clean, when I reinstall and then restore from the SAME backup file that I used to restore the program on the new machine, BArca opens with a different colour scheme and the same old SMTP problem !!
No need to uninstall Barca on your other PC, since you can use it on 2 different devices.
Also Barca doesn't write almost nothing to the registry. You could easily place the installation folder elsewhere and still it will work. 8)
So, the question then beggers the asking, where exactly is the new installation on the old machine getting the info from to default to the none standard colour scheme and to retain what ever error is causing the SMTP problem ?!?!?!!?
It's getting the info from your barca ini-file.
As for that SMTP problem I really don't know, since it did work before.
Anyone got any thoughts ????
I would install Barca yet again into another folder, but instead of deleting that old installation, just leave it.

Next go to File > Import > Data from another install on your new Barca.
Point to the previous barca ini-file, but don't import your accounts, nor Program Preferences and settings.

Image

Like I said already, after the uninstall, I cleaned the the registry with 'Registry Easy' ...
Never heard about that registry cleaner. I'm using Ace Utilities, RegSupreme Pro and TuneUp Utilities. :lol:
With the first one you do have to be careful, but it's a good one.
Just be careful with those registry cleaners, since they can do a lot of harm.
Somewhere on the OLD PC lurks a file which is affecting the restore or more likely the reinstallation from the exe file !!!
If you got the time, try my suggestion first.
See if that helps getting rid of that socket error first.

Let me know how it goes. Crossing my fingers here. ;)
Eric
 

Postby Tomas » Thu Jul 24, 2008 10:55 am

I'd try checking whether there isn't some conflict of Barca with some software you have. Try closing one after another, including firewall and antivirus if you can, to find whether closing some of these will help.
As for firewall, to minimize any possible security issues, perhaps you could shut down the software firewall and try to send a message, after that start the software firewall again and disable the firewall functionality of your router for another quick test of sending a mail.
Tomas
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Postby Eric » Thu Jul 24, 2008 9:24 pm

Tomas wrote:I'd try checking whether there isn't some conflict of Barca with some software you have.
That's the most likely reason.
Have installed Avira Premium Security and that works as it should.
No problems with Barca :), but it's another setup here.

In case of your router, did you update to the latest firmware?
It could be a connection between your router too.
Anything is possible why it does return that error.

Now I'm really gone Tomas. :lol: ;)
Eric
 

socket error ...

Postby maxicomm » Fri Aug 01, 2008 4:52 pm

Greetings to one and all ...

... and many thanks for all of your inputs. Needles to say with vague issues like this none of the suggested causes were the route of the problem. Indeed, it eventually turned out to be a Windows XP file issue. Not a registry issue which I must say is highly likely in such circumstances but a simple DLL file which was corrupt.

Don't ask me which one, as it took my network/Windows guru about 4 hours to resolve with much finger bashing and swearing. Anyway, needles to say the offending DLL has been replaced and all now appears to work as it should.

HOWEVER, isn't there always an however ... I now have the problem that whilst the problem was being resolved, I have another installation of Barca Pro running on another machine on my network. THe problem is that it's not a simple issue of backing one installation up and then restoring the other installation as many of the recent emails sent/received are now split between the two installations.

Is there any way of selectively exporting/importing messages between the 2 installations so that the existing files are not over written otherwise one way or the other I'm going to lose some of the recently sent/received emails ???

Thanks in anticipation.
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby Tomas » Sat Aug 02, 2008 10:03 am

1) Create new folders in Barca installation from which you wish to move the data.
2) Manually move the messages you wish to transfer, to those folders.

Say the folder name was MyFolder. Now find files Myfolder.mbx, Myfolder.idb and Myfolder.dat and copy them under the Mail directory (you can find out the exact path by searching for In.mbx file) of the other installation.
Start Barca and the copied folders shall appear in the folder tree.

Or you could copy whole Mail folder of one installation, as a subfolder of Mail folder of the other installation - that way you have all the data under one roof for any manipulation you wish to do on them, of course most will be duplicate.
Tomas
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Thanks ...

Postby maxicomm » Sat Aug 02, 2008 10:35 am

Thanks for that ... I knew there'd be a solution ... somewhere LOl

;-)
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Previous

Return to Barca Help and How-To

Who is online

Users browsing this forum: No registered users and 3 guests

cron