[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - problems with undescore in email-adresses

problems with undescore in email-adresses

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

problems with undescore in email-adresses

Postby Metallurge » Wed Aug 11, 2004 1:06 am

Hi!
I'm experiencing problems if I want to answer to an email from a user who has an underscore "_" in his adress.
This underscore will be replaced by a blank " " and the answer will never reach its destination :(
Is this a misconfiguration in my Poco (version 3.01) or a general problem? Fix or workaround available?

TIA
Metallurge
Metallurge
New Arrival
 
Posts: 2
Joined: Wed Aug 11, 2004 12:55 am

Postby frazmi » Wed Aug 11, 2004 1:26 am

I think I've seen that once or twice, but I can't remember the circumstances. I think it was a malformed return address, however.

You can try putting the email address in brackets, like this:
<foo_bar@somewhere.net>

Also, if the return address has a text part, like "Foo Bar", try deleting the text part and just leaving the bare email address.

I think one (or both) should preserve the underscore.
frazmi
Poco Enthusiast
 
Posts: 248
Joined: Tue Jul 27, 2004 1:27 am
Location: South Korea

Postby Metallurge » Wed Aug 11, 2004 1:42 am

wow, thanks for the fast answer!

The problem only appears while replying.

for example:
"User T <user_t@xyz.com>" will be converted to
"User T <user t@xyz.com>".
No Reply-to-adress is set, so From-adress is used.

I also have the user in my adressbook as "User T <user_t@xyz.com>", bouncing the originally missguided message works prefect.

So: IMO Poco has no problem with underscores in general, but obviously within adresses while replying.
Always fixing these adresses before sending manually is a little bit ...
Metallurge
New Arrival
 
Posts: 2
Joined: Wed Aug 11, 2004 12:55 am

Postby Andreas » Wed Aug 11, 2004 8:17 am

This was a known bug in older PocoMail versions, but it has already been fixed. Updating you PocoMail installation to the current version should fix the problem.
Andreas
Poco Enthusiast
 
Posts: 380
Joined: Sun Jul 25, 2004 5:30 pm
Location: Germany


Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 3 guests

cron