[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - SMTP hostname problem

SMTP hostname problem

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

SMTP hostname problem

Postby kaj » Mon Jul 26, 2004 7:17 am

I have recently changed ISPs and I'm now having a problem using Pocomail to send mail. This is because the new ISP claim that they more strictly follow the RFC specification about the SMTP log in conversation.

On my home network I use a Windows 2000 system that connects to the internet via a router which acts as a DHCP server and generates DNS addresses for the network, and performs NAT which keeps the local network addresses (10.0.0.x) private.

Pocomail seems to have a problem finding a host name to log into my ISP's SMTP server. This is using unauthenticated SMTP. The GetHostName system call definitely works to get the local machine name but it doesn't seem to be used.

Instead Pocomail uses the local IP address to try to sign on with the SMTP server, for example:

HELO 10.0.0.8

Now apart from the fact that I don't really want local IP addresses getting out to the the internet without NAT applied, this request is rejected by the server as the RFC says that if an IP address is used it should be enclosed in square brackets.

How can I get Pocomail to use either :
1. a hostname plus domain name, or
2. a local machine name, or
3. an external IP address in square brackets.

??

I have seen a tip about solving a similar problem with Windows 98, by making sure a host name is specified in the Network settings, but I can't find the equivalent settings in the Windows 2000 configuration. I do have a computer name specified and that name is returned when an application calls GetHostName.

Thanks for any ideas.

kaj
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Re: SMTP hostname problem

Postby robin » Mon Jul 26, 2004 9:49 am

kaj wrote:Instead Pocomail uses the local IP address to try to sign on with the SMTP server, for example:

HELO 10.0.0.8

Now apart from the fact that I don't really want local IP addresses getting out to the the internet without NAT applied, this request is rejected by the server as the RFC says that if an IP address is used it should be enclosed in square brackets.
I can't deal with the core part of your question directly because I don't have any problems with my SMTP servers but can I make some observations?

1. It really doesn't matter if your 10.x.x.x IP address 'gets out', because any other IP address trying to get to it cannot do so - it is one of a bunch reserved for private networks and there is no route to it from the internet. How does the intenet know whether it is your address or one of the many others?

2. Any reason that you are using the Class A 10.x.x.x IP address range for your home network rather than the class C 192.168.x.x? It makes no practical difference but for small networks the 192.168.x.x range tends to be used. Unless you have a very large home network :wink:

3. PocoMail has absolutely no way of knowing the internet-side address of your router and depending on the nature of your connection it could change from day to day, so PM cannot have it hardcoded or even softcoded.

4. My version of PocoMail (3.1) correctly gets the machine name from my WinXP machine - are you sure that you actually have the name in the correct place?

Beyond these comments I can't really help. I wonder why your particular ISP seems to be making everything so complicated?
robin
 

Postby kaj » Mon Jul 26, 2004 11:42 am

Thanks for the reply, Robin.

To deal with your points:

1. Yes, I agree it does no harm for my local address to get out, however the sign on command (HELO) is supposed to identify the client to the SMTP server, but a private address cannot do that.

2. The reason I'm using the 10.x.x.x range is that it is part of the default configuration for my router, ( and it's easier to remember :-) ).

3. Yes, I understand that you cannot get the external address form the local machine. But if Pocomail decides to use an IP address instead of a fully qualified domain name, according to my ISP, this should be in square brackets. Now I don't know who is right about this, but unless my ISP and Pocomail can agree then I have a problem using them together.

4. I believe I have set the name in the correct place. As an experiment I created a dummy Pocomail account which I set up for SMTP authentication. This one signed on with the correct host name:
EHLO <my-computer-name>

So why can't the non-authenticated SMTP do that ?

>I wonder why your particular ISP seems to be making everything so complicated?
Don't know. I guess they're trying to obey the rules. :(
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Postby robin » Mon Jul 26, 2004 10:53 pm

kaj wrote:4. I believe I have set the name in the correct place. As an experiment I created a dummy Pocomail account which I set up for SMTP authentication. This one signed on with the correct host name:
EHLO <my-computer-name>

So why can't the non-authenticated SMTP do that ?
Hi Kaj - I appreciate your problem and when it comes to resolving the [] problem then this is down to PSI. However the root of the problem seems to be getting the correct name out of your Win2k machine. More questions (because this problem seems to be specific to your installation making it difficult to track down an answer)...

- why not use the authenticated SMTP instead of the un-authenticated (or was this one that you 'borrowed' for the test)?

- is your PC on a network because if so then PM should just get the network name. If it is standalone and on a modem, then you may not have set the computer name up correctly.
robin
 

Postby kaj » Tue Jul 27, 2004 1:24 am

- why not use the authenticated SMTP instead of the un-authenticated (or was this one that you 'borrowed' for the test)?

I don't have an authenticated SMTP account , for the test I just used a dummy username and password, which were of course refused by the server. But this was after the successful log-on handshake ("EHLO <computer_name>") which I observed with a network monitor.
I could get an authenticated account, which may get around the problem, but having investigated this far I'd like to find out the real cause of the problem, of why Pocomail isn't getting the correct host name.

- is your PC on a network because if so then PM should just get the network name. If it is standalone and on a modem, then you may not have set the computer name up correctly.


It is on a network behind a router, how do I set up the "network name"?

Thanks again
kaj
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Postby robin » Tue Jul 27, 2004 1:58 am

Right-click on My Computer then choose Properties. On XP choose the tab called Computer Name, on 2k it is something similar, then click the button marked "To rename this computer of join a domain.." Change...

From there you can enter a computer name. Leave the workgroup blank, or you might want to put a "throwaway" name like 'Network' or 'Home'.
robin
 

Postby kaj » Tue Jul 27, 2004 2:26 am

That's how I set up my computer name. When you said "Network Name" I thought that might be something different.

I have the workgroup set to "WORKGROUP".
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Postby frazmi » Tue Jul 27, 2004 3:23 am

Well, I'm going to jump in here because my configuration seems to be identical to kaj's.

I have a NAT router, and use unauthenticated SMTP, and am using Win2KPro. Poco has no problem in connecting to my ISP.

So perhaps the problem lies in the setup?

Under Account | Outgoing I have...
[x] Account Server Settings
Server: relay.foo.com
[ ] Use Outgoing Server Authentication

Under Options | General Options | Network Settings I have...
Dial Up is blank (I have VDSL)
Proxy Settings is blank (I don't use a proxy)

My server requires me to log in to download messages before it will allow me to send messages -- since I'm accessing the internet from a different site, my ISP sees email from me as "relayed."

I'm assuming that you can ping your isp (using URL, not IP address). If not, the problem may not lie in Poco at all.
frazmi
Poco Enthusiast
 
Posts: 248
Joined: Tue Jul 27, 2004 1:27 am
Location: South Korea

Postby kaj » Tue Jul 27, 2004 4:12 am

Thanks frazmi. My set up is very similar to yours.

As I said in the thread, my system can communicate with the SMTP server. It's just that Pocomail uses the IP address instead of the computer name to try to log on to the server.

It would be interesting to see what your system does when you start to send a mail, but that's quite a low level investigation requiring that you monitor the network packets with a sniffer or something similar.

After connecting with the server the client should send the string "HELO " followed by the computer name, on my system it sends the IP address instead of the name.

kaj
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Postby robin » Tue Jul 27, 2004 4:13 am

frazmi wrote:Well, I'm going to jump in here because my configuration seems to be identical to kaj's.
Welcome aboard because I'm starting to bang my head against the desk over this one.
robin
 

Postby frazmi » Tue Jul 27, 2004 12:03 pm

kaj, you're right, I don't have a network sniffer. But I do have Poco Debug Mode, and here's what it reports:
Code: Select all
Sending message on 7/28/2004 8:58:05 AM
 Pre-send filters
 Get info on account: _RSB
 SMTP: relay.foo.com
 SMTP LOGIN
 SMTP SEND
 Post-send filters
 Save message to: Sent
 SMTP LOGOUT

220 relay.foo.com ESMTP
HELO 192.168.x.x
250 relay.foo.com
MAIL FROM:<foo@somewhere.net>
250 ok
RCPT TO:<bar@somewhere.net>
250 ok
DATA
354 go ahead

.
250 ok 1090972680 qp 26688
QUIT
221 relay.foo.com

relay.foo.com is my ISP's SMTP server.
somewhere.net is my domain (hosted on foo.com)
foo (at) somewhere.net is a secondary email address on my domain.
frazmi
Poco Enthusiast
 
Posts: 248
Joined: Tue Jul 27, 2004 1:27 am
Location: South Korea

Postby kaj » Tue Jul 27, 2004 2:46 pm

frazmi - Wow thanks, that's very useful.

How do I get Pocomail Debug Mode? That would have saved me a lot of bother tracking this problem down.

> HELO 192.168.x.x

This line tells me that your system is behaving exactly like mine, but your SMTP server is not so strict as the one I use.

I think this is a bug in Pocomail, how do I get this fixed? does the development team read these forums?

kaj
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Postby frazmi » Tue Jul 27, 2004 6:11 pm

Debug mode -- Go to Help | PocoScript, then Control-LeftClick on the word "Contents"

I'm still wondering about the "strictness" levels of our servers. Mine is pretty strict. Also, in all the time I've been using Poco and following this forum (over a year now), as far as I can remember login problems (when "PLAIN" is the method) have always turned out to be a configuration error. Now, there's always a first time for anything, so I'm not saying that it's impossible for Poco to have a bug in this area. I'm just saying that a little more snooping is worth-while.

Another idea, why not download a free evaluation version of Eudora, Becky, The Bat -- or even use *ugh* Outlook Express to verify that you can actually connect to your SMTP server. That will eliminate a host of "possibles" and in addition will yield a set of connection settings that you know work. We can then try to imitate those settings in Poco.

And a final note, do you have any software between Poco and the ISP, such as outgoing AntiVirus? If so, it would be a good thing to double-check the settings there, or even turn it off for a bit.

Bottom line of my advice, break the problem down into segments and try to figure out which segment is not working. And good luck!
frazmi
Poco Enthusiast
 
Posts: 248
Joined: Tue Jul 27, 2004 1:27 am
Location: South Korea

Postby frazmi » Tue Jul 27, 2004 6:14 pm

I just thought of another possible idea... I recall one ISP that required me to use my entire email address as the login name. That is, in the Poco outgoing SMTP authentication box for "username" I had to use foo @ somewhere.com instead of just "foo". Just a wild shot in the dark.
frazmi
Poco Enthusiast
 
Posts: 248
Joined: Tue Jul 27, 2004 1:27 am
Location: South Korea

Postby kaj » Tue Jul 27, 2004 6:55 pm

I know what the problem is at the ISP end. In fact they have put my connection on special processing that accepts the log-on string that Pocomail produces. So it is now working, although in the long term they would like me to fix it or use another email client.

There are two issues here:

1. Why can't Pocomail use the host name on the Win2000/networked configuration that you and I both have? Maybe there is some configuration that will cause it to find the host name. But the reason I don't think that it is a configuaration issue is that it uses the hostname on the Authenticated log-on:

220 relay2.tidymail.co.uk ESMTP Exim 4.34 Wed, 28 Jul 2004 07:42:22 +0100
EHLO brc-2k


but not on the unauthenticated log-on:

220 relay2.tidymail.co.uk ESMTP Exim 4.34 Wed, 28 Jul 2004 07:16:51 +0100
HELO 10.0.0.8


( That Debug mode is useful :-) )
"brc-2k" is this computer name, "10.0.0.8" is its local network address.


2. In the absence of a hostname Pocomail uses the IP (dot) address string as its log-on parameter. My ISP claims this is illegal as IP addresses as part of the domain name should be in square brackets []. Who is correct?

kaj
kaj
Poco Tourist
 
Posts: 21
Joined: Mon Jul 26, 2004 7:09 am
Location: Oxford, UK

Next

Return to PocoMail Help and How-To

Who is online

Users browsing this forum: Nagododo and 2 guests

cron