[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - How to configure Poco for Gmail

How to configure Poco for Gmail

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

How to configure Poco for Gmail

Postby wordwarrior » Thu May 29, 2008 4:44 am

I've read everything I can to make this work and thus far, have had no luck. Will some kind and knowing soul explain to me how to configure Pocomail to work with Gmail?

Thank you in advance.
wordwarrior
Drop-in Visitor
 
Posts: 8
Joined: Thu May 29, 2008 4:42 am

Postby robin » Thu May 29, 2008 5:19 am

Hi, welcome to the forums. It really is quite easy...this works for me
These are the key settings, everything else is down to your preferences.

Create a new POP3 account.

General tab:
Name & e-mail you can fill in as appropriate

Incoming server is pop.gmail.com
Username is your full gmail e-mail address
Password I hope that you know

Check Enable secure connection (SSL)

Outgoing server is smtp.gmail.com
Do not check Use same username / password for Outgoing server

Incoming tab:
Check Incoming server port number and set it to 995

Outgoing tab:
Check Outgoing server port number and set it to 465
Check Use Outgoing Server Authentication
Enter your username and password as above
Authentication type is LOGIN
Check Enable secure connection (SSL)
Do not check Use TLS / STARTTLS.

The only note of caution that I would make is that after launching gmail, google were mixed up in a copyright case where another company claimed the term "GMail". Following this gmail became googlemail. Just check the settings for your account after you have logged into the google mail web site and make sure that your account does not require googlemail.com rather that gmail.com.

If you go into the settings page after logging in and go to the POP3 / IMAP section.

Also ensure that your account is enabled for POP3.

Edit: I've checked this, and pop.googlemail.com and smtp.googlemail.com would work too.
robin
 

Postby wordwarrior » Thu May 29, 2008 5:46 am

Thank you! That was an excellent instruction and works great. I do have another question regarding Gmail. How can I keep from downloading all my gmail each time I use Poco to download mail? I have about 340 messages archived but don't want to download them each time. I just want the new messages. Any ideas?
wordwarrior
Drop-in Visitor
 
Posts: 8
Joined: Thu May 29, 2008 4:42 am

Postby Eric » Thu May 29, 2008 5:53 am

Hi wordwarrior & welcome to Poco Forums, :D
wordwarrior wrote:I just want the new messages. Any ideas?
You'll have to set that up in Gmail.

Image

Not like in this screenshot, but the second option. :)
Eric
 

Postby wordwarrior » Thu May 29, 2008 5:55 am

That's the way I have gmail set up but it still doesn't work for me.
wordwarrior
Drop-in Visitor
 
Posts: 8
Joined: Thu May 29, 2008 4:42 am

Postby Eric » Thu May 29, 2008 5:56 am

wordwarrior wrote:That's the way I have gmail set up but it still doesn't work for me.
Not like in this screenshot.
That's my setting.
You'll have to use the second option to only download new mail from now on. :)
Eric
 

Postby wordwarrior » Thu May 29, 2008 6:02 am

Thanks again. Works perfect! Thank you. You've been most helpful.
wordwarrior
Drop-in Visitor
 
Posts: 8
Joined: Thu May 29, 2008 4:42 am

Postby Eric » Thu May 29, 2008 6:11 am

My pleasure wordwarrior & enjoy Poco. :wink:
Eric
 

gmail setup

Postby Isabelle » Thu Jun 25, 2009 1:14 am

I'm stymied. I followed the instructions in this forum to the letter and still am not able to configure Pocomail for gmail.

The one big difference I see between the gmail configuration and the working configurations I have for both my ISP provider (Verizon sold all our rural lines to Fairpoint, my current provider) and for my godaddy email domain is that, unlike gmail, they do not require the SSL/TSL to be checked. Gmail requires that they be checked.

When I configure gmail as outlined in this string, I get this error:
Socket error #10060 Connection timed out.

Does anyone have any suggestions? TIA
Isabelle
Poco Tourist
 
Posts: 45
Joined: Thu Jul 14, 2005 11:36 am

Postby plong » Thu Jun 25, 2009 2:28 am

Are you trying to configure gmail/Poco for POP or IMAP?

Philip
plong
New Arrival
 
Posts: 3
Joined: Sat Nov 01, 2008 11:56 am

gmail configuration

Postby Isabelle » Thu Jun 25, 2009 5:47 am

Plong, I tried both following the very clear instructions I found in this forum... I made sure to enable POP and IMAP in my gmail settings, but had no luck with either of them.

Obviously I'm doing something wrong, but for the life of me I can't figure out what--since kind souls in this forum have posted either screen shots or explicit instructions of how to correctly configure it!
Isabelle
Poco Tourist
 
Posts: 45
Joined: Thu Jul 14, 2005 11:36 am

Re: gmail configuration

Postby Eric » Thu Jun 25, 2009 6:13 am

Isabelle wrote:Plong, I tried both following the very clear instructions I found in this forum... I made sure to enable POP and IMAP in my gmail settings, but had no luck with either of them
It's either POP or IMAP, but not both.
Obviously I'm doing something wrong, but for the life of me I can't figure out what--since kind souls in this forum have posted either screen shots or explicit instructions of how to correctly configure it!
Could you perhaps post your settings in Poco, as well as for Gmail too :?:

Leave out personal info, that's not what we need.

:idea: Or you could post some screenshots, masking personal info.
For that you need to upload your picture to ImageShack or PhotoBucket or another.
Afterwards post the link to your picture here between IMG tags.

I'm sure some setting is incorrect, so it won't work and you're getting that error over and over again. :?
Eric
 

Pocomail SMTP

Postby Isabelle » Thu Jun 25, 2009 6:57 am

Greetings, Eric. I'll copy everything exactly as I have it and post it.

One strange thing is that when I change incoming port number to 995, checke ok, ok---- and then go back to check it, I see that it reverts back to 993 every time. No problem with outgoing number, which remains at my chosen setting.

Is there anything that should be changed in IMAP Settings?
Isabelle
Poco Tourist
 
Posts: 45
Joined: Thu Jul 14, 2005 11:36 am

Re: Pocomail SMTP

Postby Eric » Thu Jun 25, 2009 7:10 am

Hi Isabelle,
Isabelle wrote:Greetings, Eric. I'll copy everything exactly as I have it and post it.
Ok, that sure will help, but don't include everything. :lol:
One strange thing is that when I change incoming port number to 995, checke ok, ok---- and then go back to check it, I see that it reverts back to 993 every time. No problem with outgoing number, which remains at my chosen setting.
Port 995 is for POP, port 993 is IMAP, so it's normal that it changes since you selected IMAP. :)
Is there anything that should be changed in IMAP Settings?
Here's my setup:

Insert your username and login
Incoming server: imap.gmail.com
Check 'Enable Secure connection (SSL)'

Outgoing server: smtp.gmail.com
Incoming port: 993
Outgoing port: 453

Check 'Use Outgoing Server Authentication'
Insert your username and login
Check 'Enable Secure connection (SSL)'
Authentication type: LOGIN

If it still doesn't work, post the requested information.

Good luck with it. ;)
Eric
 

Pocomail SMTP

Postby Isabelle » Thu Jun 25, 2009 8:08 am

Here are my settings, Eric:

My settings:

Inserted my username and login
Incoming server: imap.gmail.com
Check: Enable Secure connection (SSL)

Outgoing Server: smtp gmail.com
Incoming port: 993
Outgoing port: 453

Checked "Use Outgoing Server Authentication"
Inserted my username and login
Authentication type: LOGIN
Checked: "Enable Secure Connection (SSL)"
Checked: Use TLS/STARTTLS (tried with both checked and unchecked)

IMAP Settings: LOGIN (Tried default setting, as well--don't know if that matters)

Tried sending an email from Pocomail using my gmail address and:

Result: Socket Error 10060--connection timed out

IMAP is enabled on gmail.

Have gmail set up to forward incoming email, so would use gmail mainly for replying/sending.

Eric, the settings I also tried to use were given here on your forums:

http://www.pocosystems.com/forum/viewto ... ight=gmail

As always, thanks for your help.
Isabelle
Poco Tourist
 
Posts: 45
Joined: Thu Jul 14, 2005 11:36 am

Next

Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 3 guests

cron