[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Stunnel and error 10061

Stunnel and error 10061

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

Stunnel and error 10061

Postby annmarief » Fri Sep 10, 2004 9:00 am

Trying to configure stunnel in order to ssl for outgoing. Assume I have something wrong in the configuration but just can't see it.

Code: Select all
CheckMail=1
CheckMailTimed=1
CheckMailTimedType=1
CheckMailInterval=5
CheckMailLast=3824066315
Console=1
Email=annma****@att.net
EncryptIn=0
EncryptOut=0
EncryptPass=
Favourite=0
Name=Ann Marie
IMAPAuth=3
IMAPMailbox=Inbox
IMAPRoot=
IMAPSeparator=.
Index=0
IsIncoming=1
IsOutgoing=1
ReplyTo=annma****@att.net
POPServer=127.0.0.1
FetchAhead=0
POPPass=4D
SSL_In=0
APOP=0
IMAP=0
NNTP=0
POPUser=annma****@127.0.0.1:1109
Sig=<none>
SkipBig=0
SkipBigSize=0
SMTPAuthType=0
SMTPAuth=0
AuthTypeCRAM_MD5=1
AuthTypeLOGIN=1
AuthTypePLAIN=1
SMTPPass=4D
SMTP=127.0.0.1
SSL_Out=0
SMTPUser=annma****
SyncAmount=500
SyncAuto=0
Tag=
TemplateN=
TemplateR=
TemplateF=
TemplateB=
URL=
ExcludeFilter=0
ExcludeDownload=
IncludeFilter=0
IncludeDownload=



Stunnel conf
Code: Select all
client = yes
debug = debug
[pop3s]
accept = 127.0.0.1:1109
connect = ipostoffice.worldnet.att.net:995

[imaps]
accept = 127.0.0.1:1439
delay = yes
connect = imaps.myisp.com:993

[smtps]
accept = 127.0.0.1:259
connect = imailhost.worldnet.att.net:465




Code: Select all
Stunnel Log
2004.09.10 15:49:20 LOG5[16407471:16565271]: stunnel 4.04 on x86-pc-mingw32-gnu WIN32 with OpenSSL 0.9.7c 30 Sep 2003
2004.09.10 15:49:20 LOG7[16407471:16430043]: RAND_status claims sufficient entropy for the PRNG
2004.09.10 15:49:20 LOG6[16407471:16430043]: PRNG seeded successfully
2004.09.10 15:49:20 LOG5[16407471:16430043]: WIN32 platform: 30000 clients allowed
2004.09.10 15:49:20 LOG7[16407471:16430043]: FD 112 in non-blocking mode
2004.09.10 15:49:20 LOG7[16407471:16430043]: SO_REUSEADDR option set on accept socket
2004.09.10 15:49:20 LOG7[16407471:16430043]: pop3s bound to 127.0.0.1:1109
2004.09.10 15:49:20 LOG7[16407471:16430043]: FD 116 in non-blocking mode
2004.09.10 15:49:20 LOG7[16407471:16430043]: SO_REUSEADDR option set on accept socket
2004.09.10 15:49:20 LOG7[16407471:16430043]: imaps bound to 127.0.0.1:1439
2004.09.10 15:49:20 LOG7[16407471:16430043]: FD 120 in non-blocking mode
2004.09.10 15:49:20 LOG7[16407471:16430043]: SO_REUSEADDR option set on accept socket
2004.09.10 15:49:20 LOG7[16407471:16430043]: smtps bound to 127.0.0.1:259

Edited by Robin: 1) hid e-mail addresses 2) put listings into 'code' boxes
annmarief
New Arrival
 
Posts: 3
Joined: Fri Sep 10, 2004 8:50 am

Postby robin » Fri Sep 10, 2004 9:22 am

Hi annmarief - welcome to the forum. What exactly is the problem that you are looking for help with?
robin
 

Postby robin » Fri Sep 10, 2004 9:30 am

Might have a bit more now...a search on the internet shows that error 10061 is
The client connects to a port that is blocked or unavailable on the mail server. If the client is trying to send a message, the blocked port is 25, and if the client is trying to retrieve a message, the blocked port is 110. Refer to the error message for the protocol and port numbers.
(this from the MS site).

So, in your Poco setup, you are telling Poco to connect to localhost (127.0.0.1), but you are asking it to use the default port.
Code: Select all
POPServer=127.0.0.1
Your Stunnel settings (as far as I can tell) are expecting connection on port 1109 therefore you need to tell Poco to use port 1109; you do this by appending the port number to the IP address in Poco setup:
Code: Select all
127.0.0.1:1109


Try that.

Not sure that you need the IP address in this line though
Code: Select all
POPUser=annma****@127.0.0.1:1109
robin
 

Got it to work

Postby annmarief » Fri Sep 10, 2004 9:40 am

My problem was that I couldn't send or receive anything once I configure stunnel. I had stunnel correct but the mail settings within pocomail were incorrect. I must have figuring out the settings was a complete pain in the a$$. The example from the stunnel site wasn't even close to what was required for pocomail.

someone might want to create documentation with some samples of dsl e-mail accounts. If they are already out there, I apologize for missing them.
annmarief
New Arrival
 
Posts: 3
Joined: Fri Sep 10, 2004 8:50 am

Postby annmarief » Fri Sep 10, 2004 9:49 am

You were correct on the incoming port, I was using the default but according to the documentation on the stunnel site it indicated that you put your userid@127.0.0.1:1109 as it turned out my dsl carrier requires userid only.

Notes of interest for ATT DSL mail in case anyone else has this problem using stunnel

example:
incoming server: 127.0.0.1:1109
userid: annmarief
password: <your password>
server type: pop

do not select SSL
outgoing server: 127.0.0.1:259
select use outgoing authenication
userid: annma****@worldnet.att.net <full id including domain name is required for ATT DSL>
password: <yourpassword>
authenication type: Login
annmarief
New Arrival
 
Posts: 3
Joined: Fri Sep 10, 2004 8:50 am

Postby robin » Fri Sep 10, 2004 5:46 pm

annmarief wrote:My problem was that I couldn't send or receive anything once I configure stunnel. I had stunnel correct but the mail settings within pocomail were incorrect. I must have figuring out the settings was a complete pain in the a$$. The example from the stunnel site wasn't even close to what was required for pocomail.

someone might want to create documentation with some samples of dsl e-mail accounts. If they are already out there, I apologize for missing them.
This seems as little unfair - I use dsl and needed no changes. The problem seems to be Stunnel; the information you need on connecting PocoMail to non-default ports is given in the help file...
PocoHelp File wrote:If your Incoming Server requires a special port number to work just add the port number to the end of the server setting name, preceded by a colon. For example, to set port number 123 just add "MyServer.domain:123".
I've visited the Stunnel.org site and it seems light on actually configuration information and other users have had trouble finding a useable configuration.

annmarief wrote:You were correct on the incoming port, I was using the default but according to the documentation on the stunnel site it indicated that you put your userid@127.0.0.1:1109 as it turned out my dsl carrier requires userid only.
I think that you are getting confused between what your dsl carrier requires and what stunnel requires.

I assume that it is working now?
robin
 

Postby robin » Fri Sep 10, 2004 7:53 pm

To follow this one up a little, can you post what you are using Stunnel for? I *assume* that your ISP requires SSL for sending and receiving messages and you are using Stunnel to achive the SSL connection at your end? Did you download a complete Win32 implementation of Stunnel or did you build it yourself (the web site [stunnel.org] seems to suggest that you have to do the build yourself). The reason that I ask is that other people might be finding the same issue as you and be interested in your solution.

Thanks
robin
 


Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 2 guests

cron