[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Problems with IMAP (Work Around)

Problems with IMAP (Work Around)

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

Problems with IMAP (Work Around)

Postby chrisretusn » Tue Sep 19, 2006 2:53 am

I had a small problem with using IMAP in a new email account I just subscribed to. I figure it would be good to share the problem and the solution. The solution was mentioned in another post back in 2004 so I figured a new post would be OK.

The first problem was I could not login to my account. PocoMail would tell me Login Failed on the status bar when using Special Folder to login via IMAP.

I then fired up OE (shudder) and added an IMAP account, it worked. That leads me to believe it is a PocoMail problem.

I then fired up Ethereal and looked at the IMAP packets. The LOGIN command in PocoMail is [LOGIN username pas)wor=d]. The LOGIN command in OE is [LOGIN "username" "pas)wor=d"]. Note the quotes.

Out of curiosity I added quotes to the Username: and Password: fields in Accounts Server Settings. It actually worked, I was able to login to my IMAP account.

The ultimate solution was to not use a password the uses symbols. Once I modified my password to alpha, numeric only all problems went away.

Two things I see with this PocoMail is not handling passwords with symbols, it should as password with symbols is considered more secure. Also error reporting is weak. There should be an option to add more details. For example the error reported back by the server was "Unexpected extra argument to LOGIN". PocoMail didn't even log this problem only reported login failure on the status line.
Chris

PocoMail 4.8.0.4400 running in Slackware64 w/Wine
chrisretusn
Poco Enthusiast
 
Posts: 284
Joined: Tue May 24, 2005 12:09 am
Location: Philippines

Postby chrisretusn » Sun Apr 18, 2010 1:33 am

Gonna resurrect this old thread I created a while back. It is still valid. Perhaps it will help someone with a similar problem.

One of my accounts requires a periodic password change, I made the change to both the POP3 and IMAP accounts I had setup. Today I used my IMAP account and the account failed. POP3 still worked. Did the usual verify of settings and still no success with IMAP. So I fired up Thunderbird and added an IMAP (No encryption) account for that provider. It worked just fine.

As before, I fired up Wireshark and access the account with Thunderbird and also PocoMail (turning off SSL)

Here is the basic difference and the cause of the problem:

Thunderbird passes to the server
LOGIN "username" "password"

PocoMail passes to the server
LOGIN username password

The best solution is to change your password. I changed my password to alpha numeric and all is well. You could wrap the User Name and Password in quotes in the account settings but it does not work with SSL.

My old password had a @ and } character in them.

This only applies to IMAP and with POP3 the password worked just fine.

Again the best fix is not to use special characters in your password.

This is an old problem with PocoMail, hopefully it will be addressed in the next version.
Chris

PocoMail 4.8.0.4400 running in Slackware64 w/Wine
chrisretusn
Poco Enthusiast
 
Posts: 284
Joined: Tue May 24, 2005 12:09 am
Location: Philippines


Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 1 guest

cron