[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Problem with handling of "Mailto" command ...

Problem with handling of "Mailto" command ...

Help and advice on using Barca

Moderators: Eric, Tomas, robin

Problem with handling of "Mailto" command ...

Postby maxicomm » Tue Mar 30, 2010 11:51 pm

I have no idea whether or not this problem is directly related to the limited abilities of the Barca rendering engine which we are continually being told doesn't handle HTML like every other satisfactory rendering engine on the planet ... BUT I DO KNOW THAT THIS APPEARS TO BE A MAJOR FLAW IN THE BARCA PRO prog !!!

I, some time ago, set up an html template which I use for selling stuff on eBay occasionally. It works OK and displays all the info without problem ... HOWEVER, for some bizarre reason, BARCA Pro WILL NOT handle the MAILTO command in accordance the HTML protocol !!!!

Here's the relevant bit of code:

Image

Here's how OUTLOOK respons (correctly) ...

Image

Here's how even Googlemail respons (correctly) ...

Image

... and here's how BARCA PRO chooses to respond to the command ... :evil:

Image

Image

... placing the command in the attachments tab ... that's got to be the single most rediculous bit of inept BASIC HTML COMMAND CODE handling EVER !!!

I know the mailto command in the web page is correct and I also know that OUTLOOK and GOOGLEMAIL handle it correctly, so WHY OH WHY OH WHY can't Barca ?????? It's basic, bread and butter stuff !!!!!!!!

I should be VERY interested to know why this is happening ?????? ... as I can't figure it out !

Response awaited with interest !
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby Tomas » Wed Mar 31, 2010 11:24 am

Is the problem with Firefox? If so, if you will use Firefox menu Tools > Options, Applications tab, type mailto into the search field, and click on the arrow button next to the action field in the mailto line to show a list of applications available, does it show two entries for Pocomail or just one? If there are two entries, please select the one named "Use PocoMail (default)". Then click OK to save the settings change.

If it's selected already though, select the other one instead. Then click OK to save the settings change. Close Firefox, start it again, repeat the above to select "Use PocoMail (default)" this time and click OK to save the settings change.
Tomas
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Postby maxicomm » Wed Mar 31, 2010 10:01 pm

Tomas wrote:Is the problem with Firefox? If so, if you will use Firefox menu Tools > Options, Applications tab, type mailto into the search field, and click on the arrow button next to the action field in the mailto line to show a list of applications available, does it show two entries for Pocomail or just one? If there are two entries, please select the one named "Use PocoMail (default)". Then click OK to save the settings change.

If it's selected already though, select the other one instead. Then click OK to save the settings change. Close Firefox, start it again, repeat the above to select "Use PocoMail (default)" this time and click OK to save the settings change.


There is NO entry in the Firefox Apps tab ...

Image

When u click the link you get ...

Image
[/list]

... and if I make Barca the default email client (Outlook is currerntly set as default email client as my other half uses it for work matters), I then get ...

Image

... Barca Pro, according to the Windows 7 file manger is installed in Program Files (X86) Folder by default which I assume is the 64-bit installation location. THere is no entry for it in the Program Files folder which I assume is the 32-bit section.

Additionally I was advised to set the program properties > compatability settings as follows:

Image
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby robin » Thu Apr 01, 2010 6:50 am

according to the Windows 7 file manger is installed in Program Files (X86) Folder by default which I assume is the 64-bit installation location. THere is no entry for it in the Program Files folder which I assume is the 32-bit section.


I can't help you with the mailto: problem, but Windows 64 bit puts 64 bit programs in \Program Files\ and 32-bit programs (like Barca) in \Program Files (x86)\ - the opposite of what you have written. There is also a whole set of 32-bit Windows files in the WOW system folder (Windows on Windows).

But I have managed to recreate the problem that you are seeing...
robin
 

Postby robin » Thu Apr 01, 2010 8:07 am

Well, I do have a solution to this. Whether it should have to be done like this is a debate for another day.

This was also discussed at length in this thread which a search on "mailto" would have found.

However - in Poco (or Barca) when you click on the mailto: link, you get an option box including this at the top:

Internet Shortcut Shell Extension DLL

This technique invoves changing this entry for PocoMail (or Barca).

This means editing the registry so if you don't like doing this then don't go there - and make sure that you know how to back out.

Using regedit, navigate to:
My Computer\HKEY_CLASSES_ROOT\mailto\shell\open\command

In the right pane you will see one entry called (Default). The first step is to make a copy of the currently entry in there. Create a new String Value and call it something like "Old (Default)". Then open (Default) and copy the current value. Close (Default) and re-open "Old (Default)" - paste the copied value into here as a safe backout.

Re-open (Default). Replace the value with the following:
(Changing the program name and path to suit your installation).:
Code: Select all
"c:\program files\pocomail4\poco.exe" /m %l


Now when you click on a mailto: link, Poco (or Barca) will come up with the correct To:. This also supports the ?subject and ?body tags.

You will also find that this lists Poco as a valid option that you can set with the Application option in Firefox options.

I can't explain why Poco is unable to set itself up properly - I'm not a developer simply a user. I have tested this on Windows 7 32-bit using Firefox and Internet Explorer. I don't see why it should not work on 64-bit.[/url]
robin
 

Postby maxicomm » Thu Apr 01, 2010 10:17 am

Thank you for the input ... I'll give it a go.

And just to clarify, I did run a search for 'mailto' and it returned nothing ;-)
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby maxicomm » Thu Apr 01, 2010 10:28 am

Hi again ...

I've just re-read your response before I delve into the regedit ... and it does represent one problem for me ... that is, I do not want to sent Barca as the default mailto handler; I wish to leave OUTLOOK as the default which it currently is.

I do however need Barca to respond correctly to the mailto command when it is selected in Forefox from the popup options when the link with the attached mailto command is clicked.
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby maxicomm » Thu Apr 01, 2010 10:48 am

Alas, it does not work :-(
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby robin » Sat Apr 03, 2010 7:44 pm

I'm sorry about that - and that I can't help you further.
robin
 

Postby maxicomm » Sat Apr 03, 2010 8:12 pm

robin wrote:I'm sorry about that - and that I can't help you further.


Thank you for the input none the less.
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Follow up ...

Postby maxicomm » Tue Apr 20, 2010 12:43 am

This is definitely a Barca problem as selecting, say, Outlook as the email client to handle the mailto command renders the correct operation in as much as the new mail window opens with the mailto address in the To: field and all other relevant objects, like subject etc are all placed in their correct respective fields.

Therefore it can ONLY be a problem specific to the Barca coding.

Perhaps someone on the staff might like to take this blatant shortcoming a little more seriously and come up with a cure for this basic ill !?!?
maxicomm
Poco Tourist
 
Posts: 41
Joined: Sun Jul 06, 2008 4:40 pm

Postby DirtBall » Tue Jan 04, 2011 9:29 am

After a half day of attempting to get the MailTo working with Barca, I found two errors in the way Barca set itself up in the registry...

I am running Windows Vista Ultimate 32 so you would have to change the settings/data to match your operating system.

The parts of the registry needing changes are:

HKEY_CLASSES_ROOT\Barca mailto

and

HKEY_CLASSES_ROOT\Barca.Url.mailto

-------------------------

For: HKEY_CLASSES_ROOT\Barca mailto

The problem was that the key under "Barca mailto" called "DefaultIcon" had the key "shell" under it instead of under "Barca mailto" like is should be. So I built a new "shell" key under "Barca mailto" , then built a new key called "open" under the shell key, and then built a new key called "command" under the open key. In the command key I put in the the data "C:\Program Files\Barca2\Barca.exe" /m "%1"
( Note: quote marks are needed in data as above )

I then deleted the shell key and its sub keys that were under the "DefaultIcon" key.

(Note: data for "DefaultIcon" key: C:\PROGRA~1\Barca2\Barca.exe,-1 )


-------------------------

For: HKEY_CLASSES_ROOT\Barca.Url.mailto

This key needs to be set up just like the HKEY_CLASSES_ROOT\Barca mailto

The error was that there was no "command" key under the "open" key and they had the data in the "open" key. I needed to add the "command" key under the "open" key and remove the data in the open key, and put it in the command key.

After I completed that I was able to click any MailTo links using several different browsers, and they all open a new message window in Barca with the email address in the correct place.

Sheesh, I hope if you are having this problem, you can understand my correction and get it applied properly. I'll bet it will fix your problems also.
DirtBall
New Arrival
 
Posts: 1
Joined: Mon Jan 03, 2011 5:59 am
Location: Cudahy, WI


Return to Barca Help and How-To

Who is online

Users browsing this forum: No registered users and 1 guest

cron