[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Some emails will download, some will not

Some emails will download, some will not

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

Some emails will download, some will not

Postby cbiweb » Sat Apr 17, 2010 4:51 am

I'm having a random issue the past few days. When PM downloads my mail, it gets all of it, except every now & then a few emails won't download. Even when I view mail on server and try fetching them from there, they won't budge. Up to now they've been unimportant messages such as forum replies, spam, etc. But today there's one piece from PayPal, a purchase receipt, that won't download, and I really don't want to trash it from the server.

I have multiple accounts set up in PM (personal and a couple business accounts), but so far this is happening with only one of them.

Any idea how to fix this, and what causes it?
cbiweb
Poco Tourist
 
Posts: 36
Joined: Wed Jul 26, 2006 11:01 am
Location: Nova Scotia, Canada

Postby Tomas » Sat Apr 17, 2010 12:36 pm

Also try Online Folders instead of View Mail on Server.

Are there any error messages? (press F12 and click Log tab for the error log)

Is there some software that steps into the connection (antivirus configured to scan incoming email traffic, antispam, ...) ?
Tomas
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Postby cbiweb » Sun Apr 18, 2010 12:30 am

Online Folders shows a blank email.

Error message:
Checking mail for accounts@companyname (4/18/2010 9:08:01 AM)...

Logging into companyname.com POP server as user accounts+companyname.com...
1 message waiting on server;
Encountered error while fetching message 1:
Connection Closed Gracefully.
No messages deleted, 1 message left on server;
Logging off...


No software is affecting it. If it was, I'd assume it would affect all email, not just a specific one at random. But I checked anyway, and nothing wrong there.

Last week it was webmaster@companyname.com, and now it's accounts@companyname.com. Could it be a problem with the host?
cbiweb
Poco Tourist
 
Posts: 36
Joined: Wed Jul 26, 2006 11:01 am
Location: Nova Scotia, Canada

Postby tonnelier » Mon Apr 19, 2010 12:19 am

cbiweb wrote:Online Folders shows a blank email.

Error message:
Checking mail for accounts@companyname (4/18/2010 9:08:01 AM)...

Logging into companyname.com POP server as user accounts+companyname.com...
1 message waiting on server;
Encountered error while fetching message 1:
Connection Closed Gracefully.
No messages deleted, 1 message left on server;
Logging off...


No software is affecting it. If it was, I'd assume it would affect all email, not just a specific one at random. But I checked anyway, and nothing wrong there.

Last week it was webmaster@companyname.com, and now it's accounts@companyname.com. Could it be a problem with the host?


I received the msg you quote for a number of days after my ISP was victim of a massive spam attack last year. Once the ISP got itself sorted out, things returned to normal, but while the POP service was disrupted it was hit and miss sending/dowloading msgs.
tonnelier
Frequent Visitor
 
Posts: 57
Joined: Tue Nov 20, 2007 6:56 am
Location: Luxembourg

Postby cbiweb » Wed Aug 11, 2010 5:23 am

Still having this problem, randomly and with random email accounts. I just tried downloading the affected message with another email program, and it came in with no problem whatsoever, so apparently it is something wrong with PM itself. Does anyone have any idea what causes this, and how to fix?
cbiweb
Poco Tourist
 
Posts: 36
Joined: Wed Jul 26, 2006 11:01 am
Location: Nova Scotia, Canada

Postby Tomas » Wed Aug 11, 2010 11:04 am

The above error message "Connection closed gracefully" to my experience is usually a temporary ISP problem, or less frequently a conflict with another software (typically antivirus).

Everytime this problem happens, please check the log (press F12 and click Log tab for the error log) for error messages, chances are that for other messages it will be different than the above.

Does this problem cause all email downloading to stop until the particular email message is removed from the server? Or is it simply skipped and all other emails are downloading correctly?

No software is affecting it. If it was, I'd assume it would affect all email, not just a specific one at random.

It could affect emails (seemingly) randomly. It could also only affect one email client but not the other.
If you have an antivirus set to scan incoming emails, you could try disabling that feature. It shouldn't affect your security, emails will still be scanned with the file and background scan.
Tomas
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Postby cbiweb » Sat Aug 14, 2010 11:35 am

I have another email stuck on the server...
I disabled my firewall and anti-virus both at the same time; completely unprotected email and computer. No change.

All email on the affected email account will not download until the stuck email is removed. However, I can retrieve the "good" emails one at a time with VMOS, and fetch them from there (which is also how I find out which email is the culprit). After that, PM just keeps trying to download the "bad" email forever. After quite a few minutes it gives up, and generates this error:

Logging into mail.domain.com POP server as user username+domain.com...
1 message waiting on server;
Encountered error while fetching message 1:
Connection Closed Gracefully.
No messages deleted, 1 message left on server;
Logging off...
cbiweb
Poco Tourist
 
Posts: 36
Joined: Wed Jul 26, 2006 11:01 am
Location: Nova Scotia, Canada

Postby ianw » Sat Aug 14, 2010 8:07 pm

To my thinking, its either your ISP or PocoMail.

There are 2 things you can try, uninstall Pocomail then re-install it,
this would be as a last resort.

First try this.

Contact your ISP and explain to them what your problem is, they should look at their setup and it will be faulty or no problems.

If its OK then it will be a re-install.
If you have to do this, save your folder with all your emails and settings in it and remember where they are located in your PC.

After the reinstallation, you could use Poco to check if it is now working properly and if it is then put your previous folder containing your settings, emails etc into the new installation.

Then copy your emails etc into the new setup.

All you have to do is enter your key and a few settings, your email addresses etc.etc., all your settings will be preserved.

When I re-install Windows thats the procedure with my emails and settings.
ianw
 

Postby cbiweb » Sun Aug 15, 2010 3:46 am

Thanks, ianw. I actually don't think it's a ISP issue because the emails do download with Thunderbird on my Mac, using the same ISP. It seems to be a PM issue, so I'll have to uninstall/reinstall as you said.
cbiweb
Poco Tourist
 
Posts: 36
Joined: Wed Jul 26, 2006 11:01 am
Location: Nova Scotia, Canada

Postby blakelyg » Mon Aug 23, 2010 8:01 am

cbiweb wrote:Thanks, ianw. I actually don't think it's a ISP issue because the emails do download with Thunderbird on my Mac, using the same ISP. It seems to be a PM issue, so I'll have to uninstall/reinstall as you said.


This is about the View on Server.

Can someone confirm - when you view messages on server and subsequently mark them to get and hit process the message does not appear to be processed through incoming filters. If I do a standard download of messages there is no problem so I know the filter is triggering. Is this a know issue (enhancement or feature)?

Thanks.

G
blakelyg
Resident Poster
 
Posts: 167
Joined: Sun Jul 25, 2004 10:13 pm
Location: Laval Quebec


Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 4 guests

cron