[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Missing Attachments

Missing Attachments

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

Missing Attachments

Postby jobo » Wed Jul 28, 2004 1:19 pm

I have been testing PocoMail for the past few weeks and really like the program except for one annoying problem I'm having. On some emails with attachments there is no attachment tab while on others there are. On the emails where there is no attachment tab, there is no way to open the attachment directly from the email. My workaround is to hit "forward", which opens a new message with the attachment tab. Any thoughts about how to correct this? Anything I might be doing wrong?

Joe
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Postby COD » Wed Jul 28, 2004 1:48 pm

I've noticed that too. I have Poco set to display supported attachments inline, and it seems like it's messages with supported attachments that sometimes has this problem.

But its never been more than a minor annoyance - so I just ignore it.
COD
Resident Poster
 
Posts: 154
Joined: Mon Jul 26, 2004 2:49 am
Location: Fredericksburg, VA

Postby robin » Thu Jul 29, 2004 7:34 pm

If you look closer I think that you will find attachment tabs are only available for attachments that can be displayed by Poco. I'm not sure of the full list but it will be limited to the likes of .txt, .jpeg, .gif... In other words if your attachment is a Word document or a ZIP file then Poco will not display it inline.
robin
 

Postby jobo » Thu Jul 29, 2004 9:42 pm

If PocoMail is designed to not show a tab in certain instances, how are you supposed to access the attachment? In my case, there is neither a tab nor a link to the attachment -- at least I can't find one. Surely, they didn't intend that users would have to create a forwarded email to view a Word or PDF document, as I have learned to do.
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Postby Eric » Thu Jul 29, 2004 11:20 pm

jobo wrote:If PocoMail is designed to not show a tab in certain instances, how are you supposed to access the attachment? In my case, there is neither a tab nor a link to the attachment -- at least I can't find one. Surely, they didn't intend that users would have to create a forwarded email to view a Word or PDF document, as I have learned to do.
:roll: Is the attachment pane activated?
View -> View attachment pane
Do you see a checkmark next to it? If not, activate it.
Eric
 

Postby Pete » Fri Jul 30, 2004 3:27 am

Yes, what Robin and Eric said. Also, make sure that the Attachment Pane is not minimized. You unminimize this by clicking on the narrow, vertical "button" that is located along the left edge of the Attachment Pane, in the middle.
Pete
 

Postby Pete » Fri Jul 30, 2004 4:10 am

Also, if that fails, you might have to resize the pane. You can do this by dragging the left edge of the pane farther to the left. (If this doesn't work, click its minimize button and then try it again.)
Pete
 

Postby jobo » Fri Jul 30, 2004 4:47 am

Eric wrote:[:roll: Is the attachment pane activated?
View -> View attachment pane
Do you see a checkmark next to it? If not, activate it.

The attachment pane is activated. Apparently, only supported attachments bring up an attachment pane. All others -- such as Word and PDF -- cannot be viewed without first forwarding the message. When that is done, an attacment tab shows up on the forwarded message. Any other thoughts?
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Postby Eric » Fri Jul 30, 2004 5:00 am

jobo wrote:The attachment pane is activated. Apparently, only supported attachments bring up an attachment pane.
:idea: When opening the attachment pane, rightclick on the attachment to view the options of Open attachtment, Save, ...
Word, PDF and others are present in my attachment pane.
Image

edit: adding picture
Last edited by Eric on Fri Jul 30, 2004 5:21 am, edited 2 times in total.
Eric
 

Postby Pete » Fri Jul 30, 2004 5:10 am

Joe, note also that the "attachments" tab that you see next to the "headers" tab at the top of a window only appears when you are using the Composition Window. You only use the Composition Window when you create a new message or reply/forward/bounce an existing message. Otherwise, if you are simply looking at an existing message, there will never be an "attachments" tab at the top of the window. You have to use the Attachment Pane instead (on the right side of the window).
Pete
 

Postby jobo » Fri Jul 30, 2004 6:18 am

Pete wrote:Joe, note also that the "attachments" tab that you see next to the "headers" tab at the top of a window only appears when you are using the Composition Window. You only use the Composition Window when you create a new message or reply/forward/bounce an existing message. Otherwise, if you are simply looking at an existing message, there will never be an "attachments" tab at the top of the window. You have to use the Attachment Pane instead (on the right side of the window).

I think I figured it out. If "View Attachments Pane" is enabled and the attachment is supported, the attachment appears both in the Pane and a link at the top of the email. If the attachment is not supported, it does not appear in either place. On the other hand, if I disable "View Attachments Pane", the attachment is accessible via a link at the top of the email whether or not the attachment is supported. I don't know if this is the way it's supposed to work, but that is what I am experiencing.
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Postby Alpha » Fri Jul 30, 2004 6:40 am

jobo wrote: All others -- such as Word and PDF -- cannot be viewed without first forwarding the message. When that is done, an attacment tab shows up on the forwarded message.


For the sake of the novice user visiting this forum, as Eric pointed out, the above quote is incorrect.
Alpha
 

Postby jobo » Fri Jul 30, 2004 8:10 am

Eric wrote:
jobo wrote:The attachment pane is activated. Apparently, only supported attachments bring up an attachment pane.
:idea: When opening the attachment pane, rightclick on the attachment to view the options of Open attachtment, Save, ...
Word, PDF and others are present in my attachment pane.
Image

edit: adding picture

Sorry for the confusion. I'm usually pretty good with computer programs. Apparently, from your screenshot there is a difference between the attachment tab and the attachment pane. What I was referring to before was the attachment tab. While I have "View Attachment Pane" selected, it does not appear. Is there another setting that might be affecting this?
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Postby Eric » Fri Jul 30, 2004 8:44 am

jobo wrote:Sorry for the confusion. I'm usually pretty good with computer programs.
Can happen to anyone. :wink:
Apparently, from your screenshot there is a difference between the attachment tab and the attachment pane.
Yes, like Pete mentionned it, there's definitely a difference.
Attachment tab: Attaching a file to a new message or reply/forward/bounce messages, displays this tab inside the composition window.
Attachment pane: Receiving or Sending messages (or draft) with attachments displays this pane.
What I was referring to before was the attachment tab. While I have "View Attachment Pane" selected, it does not appear. Is there another setting that might be affecting this?
The attachment pane only appears if there are attachments. The attachment tab only appears if you add an attachment to a new message or reply/forward/bounce.
If you've activated to view the attachment pane, then you should see it, when there's an attachment.
I hope this helps.
Last edited by Eric on Fri Jul 30, 2004 1:00 pm, edited 1 time in total.
Eric
 

Postby jobo » Fri Jul 30, 2004 9:08 am

The attachment pane only appears if there are attachments. The attachmentment tab only appears if you add an attachment to a new message or reply/forward/bounce.
If you've activated to view the attachment pane, then you should see it, when there's an attachment.
I hope this helps.

I realize that the attachment pane is supposed to appear only when I have attachments. I am not getting a separate window like the one on the right side in your screen shot, whether or not I have attachments and whether or not I have View Attachment Pane. When I do have an attachment and View Attachment Pane selected, I have two tabs -- on the bottom on the preview pane and on the rights when I open the message. I only get the tabs when I have an attachment that is supported. I realize from the posts that this is not the way it's supposed to work, but that's what's going on here. Having said that, I think I recall that when I first started using PocoMail I did have an attachment pane. I don't know where it went or how to get it back.
jobo
Drop-in Visitor
 
Posts: 7
Joined: Wed Jul 28, 2004 1:07 pm

Next

Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 4 guests

cron